const regex = /!!!\s*([^?]+?)\s*\?{3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('!!!\\s*([^?]+?)\\s*\\?{3}', 'g')
const str = `Image 56 ::: Beach, Summer, Sun !!! John Smith ???
Image 57 ::: Beach, Summer, Sun !!!Jane Doe???
Image 58 ::: Beach, Summer, Sun !!! Jack Johnson???`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}