#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)league/((?P<league_slug>[\w-]+)(/(?P<season_slug>\d{4}(-\d{4})?))?(/(?P<action_slug>[\w\-\_]+[(-|_)]?[\w]+))?)?(/)?"
Local $sString = "http://localhost:8010/league" & @CRLF & _
"http://localhost:8010/league/" & @CRLF & _
"http://localhost:8010/league/serie-a" & @CRLF & _
"http://localhost:8010/league/serie-a/" & @CRLF & _
"http://localhost:8010/league/serie-a/2016" & @CRLF & _
"http://localhost:8010/league/serie-a/2016/" & @CRLF & _
"http://localhost:8010/league/serie-a/2015-2016" & @CRLF & _
"http://localhost:8010/league/serie-a/2015-2016/" & @CRLF & _
"http://localhost:8010/league/serie-a/s-t-a-n-d-i-n-g-s" & @CRLF & _
"http://localhost:8010/league/serie-a/stand_-aasdings/" & @CRLF & _
"http://localhost:8010/league/serie-a/2016/standings" & @CRLF & _
"http://localhost:8010/league/serie-a/2016/standings/" & @CRLF & _
"" & @CRLF & _
"http://localhost:8010/league/2016" & @CRLF & _
"http://localhost:8010/league/2016/" & @CRLF & _
"http://localhost:8010/league/standings" & @CRLF & _
"http://localhost:8010/league/standings/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")