using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"league/((?P<league_slug>[\w-]+)(/(?P<season_slug>\d{4}(-\d{4})?))?(/(?P<action_slug>[\w\-\_]+[(-|_)]?[\w]+))?)?(/)?";
string input = @"http://localhost:8010/league
http://localhost:8010/league/
http://localhost:8010/league/serie-a
http://localhost:8010/league/serie-a/
http://localhost:8010/league/serie-a/2016
http://localhost:8010/league/serie-a/2016/
http://localhost:8010/league/serie-a/2015-2016
http://localhost:8010/league/serie-a/2015-2016/
http://localhost:8010/league/serie-a/s-t-a-n-d-i-n-g-s
http://localhost:8010/league/serie-a/stand_-aasdings/
http://localhost:8010/league/serie-a/2016/standings
http://localhost:8010/league/serie-a/2016/standings/
http://localhost:8010/league/2016
http://localhost:8010/league/2016/
http://localhost:8010/league/standings
http://localhost:8010/league/standings/";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}