import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "league/((?P<league_slug>[\\w-]+)(/(?P<season_slug>\\d{4}(-\\d{4})?))?(/(?P<action_slug>[\\w\\-\\_]+[(-|_)]?[\\w]+))?)?(/)?";
final String string = "http://localhost:8010/league\n"
+ "http://localhost:8010/league/\n"
+ "http://localhost:8010/league/serie-a\n"
+ "http://localhost:8010/league/serie-a/\n"
+ "http://localhost:8010/league/serie-a/2016\n"
+ "http://localhost:8010/league/serie-a/2016/\n"
+ "http://localhost:8010/league/serie-a/2015-2016\n"
+ "http://localhost:8010/league/serie-a/2015-2016/\n"
+ "http://localhost:8010/league/serie-a/s-t-a-n-d-i-n-g-s\n"
+ "http://localhost:8010/league/serie-a/stand_-aasdings/\n"
+ "http://localhost:8010/league/serie-a/2016/standings\n"
+ "http://localhost:8010/league/serie-a/2016/standings/\n\n"
+ "http://localhost:8010/league/2016\n"
+ "http://localhost:8010/league/2016/\n"
+ "http://localhost:8010/league/standings\n"
+ "http://localhost:8010/league/standings/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}