import re
regex = re.compile(r"league/((?P<league_slug>[\w-]+)(/(?P<season_slug>\d{4}(-\d{4})?))?(/(?P<action_slug>[\w\-\_]+[(-|_)]?[\w]+))?)?(/)?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("http://localhost:8010/league\n"
"http://localhost:8010/league/\n"
"http://localhost:8010/league/serie-a\n"
"http://localhost:8010/league/serie-a/\n"
"http://localhost:8010/league/serie-a/2016\n"
"http://localhost:8010/league/serie-a/2016/\n"
"http://localhost:8010/league/serie-a/2015-2016\n"
"http://localhost:8010/league/serie-a/2015-2016/\n"
"http://localhost:8010/league/serie-a/s-t-a-n-d-i-n-g-s\n"
"http://localhost:8010/league/serie-a/stand_-aasdings/\n"
"http://localhost:8010/league/serie-a/2016/standings\n"
"http://localhost:8010/league/serie-a/2016/standings/\n\n"
"http://localhost:8010/league/2016\n"
"http://localhost:8010/league/2016/\n"
"http://localhost:8010/league/standings\n"
"http://localhost:8010/league/standings/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")