use strict;
my $str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit.
NOT MATCHED in HERE Vestibulum vehicula arcu cursus justo luctus gravida. Praesent elefur dictum sollicitudin.
begin
Nullam mi justo, pulvinar sit amet leo sed, commodo malesuada nulla.
but MATCHED HERE Donec lobortis arcu eget turpis commodo, sed interdum leo OK elefur.
end
NOT MATCHED HERE
Cras venenatis felis vel nisi elementum varius.
Proin TEST sed magna sed erat consequat pretium eu sit amet nibh.';
my $regex = qr/.*begin|end.*|[^e]*?\b([A-Z]{2,})\b/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}