import Foundation
let pattern = #".*begin|end.*|[^e]*?\b([A-Z]{2,})\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Lorem ipsum dolor sit amet, consectetur adipiscing elit.
NOT MATCHED in HERE Vestibulum vehicula arcu cursus justo luctus gravida. Praesent elefur dictum sollicitudin.
begin
Nullam mi justo, pulvinar sit amet leo sed, commodo malesuada nulla.
but MATCHED HERE Donec lobortis arcu eget turpis commodo, sed interdum leo OK elefur.
end
NOT MATCHED HERE
Cras venenatis felis vel nisi elementum varius.
Proin TEST sed magna sed erat consequat pretium eu sit amet nibh.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)