import Foundation
let pattern = #"^$|^(http(s)?:\/\/([a-zA-Z0-9.-]*)(:\d{0,5})?,?)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://192.168.1.100:32400,http://192.168.1.100:32400,http://sasdfds.com
http://sasd-fds.com
http://GASGH-ASD.com
https://sasd-fds.test.long.com
http://192.168.1.100:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)