using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((est)\s[0-9]?[0-9]?(ème))\s?(de)?\s?(L1)?";
string input = @"Bordeaux est 8ème de L1. ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}