$re = '/((est)\s[0-9]?[0-9]?(ème))\s?(de)?\s?(L1)?/m';
$str = 'Bordeaux est 8ème de L1. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);