#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<operator>[+\-])?(?:(?<dice>(?<numberOfDice>[\d]+)?[dD](?<faces>[\d]+)(?<explode>![\d]*)?(?<implode>¡[\d]*)?(?<selective>[kd][\d]+)?)|(?<constant>[\d]+))"
Local $sString = "d4" & @CRLF & _
"1d4" & @CRLF & _
"1d20-10" & @CRLF & _
"2d6+1d8" & @CRLF & _
"3d10k2" & @CRLF & _
"3d10d2" & @CRLF & _
"6d6!" & @CRLF & _
"6d6!5" & @CRLF & _
"d100!96¡5" & @CRLF & _
"d6¡" & @CRLF & _
"d20¡2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")