# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z1-9])\1{2,}/\1\1-/gm;t' <<< "111aabbccxccybbzaa1"