using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bjson\b(?:(?!\bfrom\b).)+\bjson\b";
string input = @"select json,json from XXX
select json from json XXXX
select json,json from json XXX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}