$re = '/(?<major>\d+)[.](?<minor>\d+)[.](?<patch>\d+)([-](?<prerelease>[a-zA-Z0-9]*[^+]))?\b([+](?<buildCounter>\d+))?/m';
$str = '0.12.3
0.12.3-alpha0001+12
0.12.3-SNAPSHOT+12
0.12.3-RC1+1
0.12.3-beta1+1333
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);