#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d+\."
Local $sString = "1." & @CRLF & _
                "2." & @CRLF & _
                "3." & @CRLF & _
                "4." & @CRLF & _
                "5." & @CRLF & _
                "6." & @CRLF & _
                "7." & @CRLF & _
                "8." & @CRLF & _
                "9." & @CRLF & _
                "10." & @CRLF & _
                "11." & @CRLF & _
                "12." & @CRLF & _
                ""
Local $sSubst = "1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)