using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\.";
string substitution = @"1.";
string input = @"1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}