# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+\."
test_str = ("1.\n"
"2.\n"
"3.\n"
"4.\n"
"5.\n"
"6.\n"
"7.\n"
"8.\n"
"9.\n"
"10.\n"
"11.\n"
"12.\n")
subst = "1."
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.