# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<[^>]*class=(\"|'))(\b(foo)(\w|\-)*)*"
test_str = ("<body>\n"
" <div style=\"margin-left:6px;\" class=\"foo-pink blfoo-pin-foo-kue red yellow bar-green -moz-FF foo-pink moz-FF foo-pink\" >\n"
" <fieldset class=\"foo customClass foo clFieldsBar bar-try\" id=\"idField foo- bar-dfgdgdfg\"> \n"
" <legend><span>Qu'en pensez-vous ?</span></legend>\n"
" < id=\"idText\" class='foo- Comment_text fdgdgdfg -foo-ddede mso-whitespace' name=\"nameText barName\"></textarea> bar-deded foo-green\n"
" </fieldset>\n"
" class=\"blue dffsf sdf mso-green foo\"\n"
" </div> \n"
"</body>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.