const regex = /function (.*).*\((.*)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('function (.*).*\\((.*)\\)', 'g')
const str = `PLAYER_BUFF_MINUTES = 10
FORCE_BUFF_MINUTES = 30
-- ------------------------------------------------------------------------------------
CHARGE_ENERGY = 100000
local charging_station_multiplier = 1
function ResetPlayer(playername)
if (game.players[playername] ~= nil) then
RemoveOrResetPlayer(game.players[playername], false, true, true, true)
SeparateSpawnsPlayerCreated(game.players[playername].index, true)
end
end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}