// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"function (.*).*\((.*)\)").unwrap();
let string = "PLAYER_BUFF_MINUTES = 10
FORCE_BUFF_MINUTES = 30
-- ------------------------------------------------------------------------------------
CHARGE_ENERGY = 100000
local charging_station_multiplier = 1
function ResetPlayer(playername)
if (game.players[playername] ~= nil) then
RemoveOrResetPlayer(game.players[playername], false, true, true, true)
SeparateSpawnsPlayerCreated(game.players[playername].index, true)
end
end";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}