package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https?:\/\/(www\.)?`)
var str = `https://www.raise.me/s/IsdsN
http://localhost/s/ISdsN
https://staging.raise.me/s/IsdsN
https://raise.me/s/IsdsN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}