import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(www\\.)?";
final String string = "https://www.raise.me/s/IsdsN\n"
+ "http://localhost/s/ISdsN\n"
+ "https://staging.raise.me/s/IsdsN\n"
+ "https://raise.me/s/IsdsN";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}