#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\((.*?)\)(\s?)"
Local $sString = "(a) b" & @CRLF & _
"There are (brackets) somewhere" & @CRLF & _
"(aa) adawidojawoi jadwjo awawdi (awidjoawidj)."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)