using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.*?)\)(\s?)";
string substitution = @"";
string input = @"(a) b
There are (brackets) somewhere
(aa) adawidojawoi jadwjo awawdi (awidjoawidj).";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}