use strict;
my $str = '(a) b
There are (brackets) somewhere
(aa) adawidojawoi jadwjo awawdi (awidjoawidj).';
my $regex = qr/\((.*?)\)(\s?)/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";