$re = '/\((.*?)\)(\s?)/mi';
$str = '(a) b
There are (brackets) somewhere
(aa) adawidojawoi jadwjo awawdi (awidjoawidj).';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;