re = /\((.*?)\)(\s?)/mi
str = '(a) b
There are (brackets) somewhere
(aa) adawidojawoi jadwjo awawdi (awidjoawidj).'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result