# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#(\d+) @ (\d+),(\d+): (\d+)x(\d+)"
test_str = ("#1 @ 338,764: 20x24\n"
"#2 @ 80,667: 12x26\n"
"#3 @ 625,36: 17x22\n"
"#4 @ 196,235: 25x13\n"
"#5 @ 610,700: 25x21\n"
"#6 @ 590,831: 20x13\n"
"#7 @ 253,201: 29x22\n"
"#8 @ 921,577: 15x13\n"
"#9 @ 495,85: 20x19\n"
"#10 @ 397,589: 17x22")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.