import Foundation
let pattern = ##"#(\d+) @ (\d+),(\d+): (\d+)x(\d+)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#1 @ 338,764: 20x24
#2 @ 80,667: 12x26
#3 @ 625,36: 17x22
#4 @ 196,235: 25x13
#5 @ 610,700: 25x21
#6 @ 590,831: 20x13
#7 @ 253,201: 29x22
#8 @ 921,577: 15x13
#9 @ 495,85: 20x19
#10 @ 397,589: 17x22
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)