$re = '/\d{2}(?=(?:\d{2})+$)/m';
$str = 'ACAC | 0 | 01
ACAC | 0 | 0101
ACAC | 0 | 0102
ACAC | 0 | 010201';
$subst = "$0/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;