using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|\()[^)(]*+\K(\(((?>[^)(]+|(?1))*)\))";
string substitution = @"$2";
string input = @"Record ID
What is the best food? (choice=Nachos)
What is the best food? (choice=Tacos (big bent nachos))
What is the best food? (choice=Chips with stuff)
Complete?
So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))
Deeper nesting: (l0 (l1 (l2) l1 (l2) l1)) out (a (b) (b) a ((c) b)) out (no)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}