import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)|\\()[^)(]*+\\K(\\(((?>[^)(]+|(?1))*)\\))";
final String string = "Record ID\n"
+ "What is the best food? (choice=Nachos)\n"
+ "What is the best food? (choice=Tacos (big bent nachos))\n"
+ "What is the best food? (choice=Chips with stuff) \n"
+ "Complete?\n\n"
+ "So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))\n\n"
+ "Deeper nesting: (l0 (l1 (l2) l1 (l2) l1)) out (a (b) (b) a ((c) b)) out (no)";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}