# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\G(?!^)|\()[^)(]*+\K(\(((?>[^)(]+|(?1))*)\))"
test_str = ("Record ID\n"
"What is the best food? (choice=Nachos)\n"
"What is the best food? (choice=Tacos (big bent nachos))\n"
"What is the best food? (choice=Chips with stuff) \n"
"Complete?\n\n"
"So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))\n\n"
"Deeper nesting: (l0 (l1 (l2) l1 (l2) l1)) out (a (b) (b) a ((c) b)) out (no)")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.