# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|^genre:\h*").*?\K",\h*"/, /gmi;t' <<< "genre: \"drama\", \"thriller\", \"mystery\", \"espionage\"
genre: \"drama\", \"sci-fi\"
NOT genre: \"drama\", \"sci-fi\""