import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)|^genre:\\h*\").*?\\K\",\\h*\"";
final String string = "genre: \"drama\", \"thriller\", \"mystery\", \"espionage\"\n"
+ "genre: \"drama\", \"sci-fi\"\n"
+ "NOT genre: \"drama\", \"sci-fi\"";
final String subst = ", ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}