#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)declare\s+@([^\s]+)\s+(?:as\s+)?table"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"declare @myTable as table" & @CRLF & _
"(" & @CRLF & _
" id int " & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"declare @myTable1 table" & @CRLF & _
"(" & @CRLF & _
" id int " & @CRLF & _
")"
Local $sSubst = "CREATE TABLE #$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)