use strict;
my $str = '
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)';
my $regex = qr/declare\s+@([^\s]+)\s+(?:as\s+)?table/mip;
my $subst = 'CREATE TABLE #$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";