// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)declare\s+@([^\s]+)\s+(?:as\s+)?table").unwrap();
let string = "
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)";
let substitution = "CREATE TABLE #$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}