#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\d\.\d*\*?)([\*\.,])"
Local $sString = " 1 ****TABLE1****" & @CRLF & _
" COLUMN1= 1.12, 2.23, 3.34, 4.45, 5.56, 6.67, " & @CRLF & _
" COLUMN2= 0.00, 0.00, 0.00, 0.00, 0.00, 0.00," & @CRLF & _
" COLUMN3= 1.23, 0.34, 3.45, 5.78*, 6.54*, 8.23.," & @CRLF & _
" 1 ****TABLE2****"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")