# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/public ([^ ]++) ([a-z])([^ ]*+) { get; set; }/[JsonPropertyName("$2$3")]\npublic $1 \U$2\E$3 { get; set; }/gm;t' <<< "public string symbol { get; set; }
public string pair { get; set; }
public string contractType { get; set; }
public string status { get; set; }
public string baseAsset { get; set; }
public string quoteAsset { get; set; }
public string marginAsset { get; set; }"