import Foundation
let pattern = #"public ([^ ]++) ([a-z])([^ ]*+) { get; set; }"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
public string symbol { get; set; }
public string pair { get; set; }
public string contractType { get; set; }
public string status { get; set; }
public string baseAsset { get; set; }
public string quoteAsset { get; set; }
public string marginAsset { get; set; }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[JsonPropertyName("$2$3")]\npublic $1 \U$2\E$3 { get; set; }"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)