#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[/?&](?:e|vi?|ci)(?:[/=]|%3D)|youtu\.be/|embed/|/user/[^/]+#p/(?:[^/]+/)+)\K[\w-]{10,12}"
Local $sString = "https://www.youtube.com/watch?v=-SXKV0jDxuA" & @CRLF & _
"https://www.youtube.com/watch?v=ylfhCpi9AEU" & @CRLF & _
"http://www.youtube.com/watch?v=-wtIMTCHWuI" & @CRLF & _
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1" & @CRLF & _
"http://youtu.be/-wtIMTCHWuI" & @CRLF & _
"http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json" & @CRLF & _
"http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg" & @CRLF & _
"http://youtu.be/zc0s358b3Ys" & @CRLF & _
"http://www.youtube.com/embed/zc0s358b3Ys" & @CRLF & _
"http://www.youtube.com/watch?v=zc0s358b3Ys" & @CRLF & _
"http://www.youtube.com/v/ZTUVgYoeN_b?f=gdata_standard" & @CRLF & _
"https://www.youtube.com/embed/WVZpCdHq3Qg" & @CRLF & _
"http://www.youtube.com/watch?argv=xyz&v=u8nQa1cJyX8" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o" & @CRLF & _
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"http://www.youtube.com/embed/0zM3nApSvMg?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg" & @CRLF & _
"http://youtu.be/0zM3nApSvMg" & @CRLF & _
"youtube.com/shared?ci=MZZ02_0O6GQ" & @CRLF & _
"//www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0" & @CRLF & _
"http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo" & @CRLF & _
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I" & @CRLF & _
"http://www.youtube.com/user/SilkRoadTheatre#p/a/u/2/6dwqZw0j_jY" & @CRLF & _
"http://youtu.be/6dwqZw0j_jY" & @CRLF & _
"http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be" & @CRLF & _
"http://youtu.be/afa-5HQHiAs" & @CRLF & _
"http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel" & @CRLF & _
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub" & @CRLF & _
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I" & @CRLF & _
"http://www.youtube.com/embed/nas1rJpm7wY?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=peFZbP64dsU" & @CRLF & _
"http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player" & @CRLF & _
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player" & @CRLF & _
"https://www.youtube.com/watch?v=UzRtrjyDwx0" & @CRLF & _
"https://youtu.be/6butf1tEVKs?t=22s" & @CRLF & _
"https://youtu.be/R46-XgqXkzE?t=2m52s" & @CRLF & _
"http://youtu.be/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/?v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/?v=dQw4w9WgXcQ&feature=player_embedded" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=player_embedded" & @CRLF & _
"http://www.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/embed/dQw4w9WgXcQ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")