#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\Q/path/to/dir/\E\K.+"
Local $sString = "/path/to/dir/file1" & @CRLF & _
"/path/to/dir/file2" & @CRLF & _
"/path/to/dir/" & @CRLF & _
"/path/to/dirt" & @CRLF & _
"/wrong/path/to/dir/file1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")