$re = '`^\Q/path/to/dir/\E\K.+`m';
$str = '/path/to/dir/file1
/path/to/dir/file2
/path/to/dir/
/path/to/dirt
/wrong/path/to/dir/file1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);