re = /^\Q\/path\/to\/dir\/\E\K.+/m
str = '/path/to/dir/file1
/path/to/dir/file2
/path/to/dir/
/path/to/dirt
/wrong/path/to/dir/file1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end