import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\@\\w+\\.\\w+";
final String string = "lastname,firstname,surname,organization,position,phone,email\n"
+ "Усольцев Олег Валентинович,,,ФНС,главный специалист – эксперт отдела взаимодействия с федеральными органами власти Управления налогообложения имущества и доходов физических лиц,+7 (495) 913-04-78,opendata@nalog.ru\n"
+ "Мартиняхин Виталий Геннадьевич,,,ФНС,,+74959130037,\n"
+ "Наркаев,Вячеслав Рифхатович,,ФНС,,8 495-913-0168,\n"
+ "Мартиняхин,Виталий,Геннадьевич,ФНС,cоветник отдела Интернет проектов Управления информационных технологий,,,\n"
+ "Лукина Ольга Владимировна,,,Минфин,,+7 (495) 983-36-99 доб. 2926,Olga.Lukina@minfin.ru\n"
+ "Паньшин Алексей Владимирович,,,Минфин,,8(495)748-49-73,1248@minfin.ru\n"
+ "Лагунцов Иван Алексеевич,,,Минфин,,+7 (495) 913-11-11 (доб. 0792),\n"
+ "Лагунцов Иван,,,,,,Ivan.Laguntcov@minfin.ru";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}