package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/id=[0-9]+$`)
var str = `https://domain.com/id=13234
https://domain.com/id=23443-wrong-part
https://domain.com/id=wrong-non-number-id`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}