// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})\.(\d+).\|(.*?)\|(.*?)\|(.*?)\|(.*?)\|(.*)").unwrap();
let string = "# 2017-07-19T09:06:44.115456Z|i|6868|11048|pfup|login: Login failed -- primary authentication for abes667 failed
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}