# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\w\W]+?Code[\w\W]+?(?<po_number>\d{8})\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s|\s\|[\w\W]+?\s\|[\w\W]+?\s\|\s(?<reason>[\w\W]+?)\|"
test_str = ("The Acme Corp has requested you cancel the following order(s) as soon as possible.\n"
"If you're unable to cancel the order(s), or have questions about the reason for canceling, please contact Acme Corp directly.\n"
"For the best support, please do not reply to this email. \n\n"
"PO# | Order Received On | Ship-to Zip Code\n"
"12345678 | 2024-03-21 18:26:54 | \n\n"
" Line # | Merchant SKU | Vendor SKU | Cancel Qty | Cancel Reason | Packing Slip Bundle\n"
" 1 | 1XX718YY40 | 654321 | 1 | Cancelled at Merchant's Request | 19205839\n\n"
"Depending on the business rules, you may need to include some of these details on the fulfillment confirmation you use to cancel the order.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.