const regex = /^((((\+972)|0)(([234689]\d{7})|([57]\d{8}))|(1[5789]\d{8}))|\*\d{3,6})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((((\\+972)|0)(([234689]\\d{7})|([57]\\d{8}))|(1[5789]\\d{8}))|\\*\\d{3,6})$', '')
const str = `1700709100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}